What are the system requirements to use JIDS?

What are the system requirements to use JIDS?

JIDS is a web-based application that functions within a web browser to process PDF forms using Adobe PDF Reader. 

Supported Browsers

Microsoft Internet Explorer 9, 10, and 11 and Mozilla Firefox through version 51 support JIDS without a separate viewer download required.

Note: Microsoft Internet Explorer versions 9 and 10 will work with JIDS, but support has been phased out for these browsers by Microsoft and by the JIDS software vendor, FileBound. Therefore, if any issues arise that are specific to those browser versions, no fixes will be applied. The recommendation is for the user to upgrade to Internet Explorer 11. 

For users with Google Chrome, Microsoft Edge, and Mozilla Firefox version 52 and up a separate forms viewer called the Windows Viewer must be downloaded to use Adobe PDF with JIDS.  For instructions, click here

Adobe PDF Reader

In order to view the electronic forms, a user must have Adobe PDF Reader installed on their machine and set to open PDF documents within the web browser. Click here to download Adobe Acrobat Reader.

JAVA 

JIDS requires Java:

Click here to determine whether or not you have Java installed. Click here to install the latest version of Java.

 

Adobe Flash Player

JIDS requires Adobe Flash Player:

Click here to determine whether or not you have Adobe Flash Player installed. Click here to install the latest version of Adobe Flash Player.

 

JIDS also requires that session cookies are enabled on a user's browser. Click here to learn more.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk